[vcf-midatlantic] Running Windows 1.04 in emulation

william degnan billdegnan at gmail.com
Wed Apr 27 22:04:20 EDT 2016


The model 25 collegiate kit ran 1.04 on two 720k disks with a ps/2 mouse.

Bill Degnan
twitter: billdeg
vintagecomputer.net
On Apr 27, 2016 9:35 PM, "Richard Cini via vcf-midatlantic" <
vcf-midatlantic at lists.vintagecomputerfederation.org> wrote:

> All —
>
> I’m progressing well with the Windows 1.04 SDK -- I’ve gotten all of the
> binders and books scanned. The software is fully captured and I’m trying to
> create a “build environment” for this as a demo.
>
> I’ve tried to get Windows to work properly in various combinations of
> virtual environments with limited success. I’ve used Parallels on the Mac,
> VirtualBox on the Mac and PC, Bochs on the PC and Microsoft Virtual PC on
> the PC. I have a complete log of my findings if anyone’s interested.
>
> Only Parallels on the Mac worked completely. On Microsoft VirtualPC under
> Windows 7, it almost worked, but button clicks didn’t register. Bochs was
> the worst performer.
>
> Most of the issues have to do with capturing the mouse — Windows 1
> predated PS/2 mice so a mouse has to be mapped to the virtual COM port or
> the InPort bus interface, which the virtualizations seemingly do with
> limited success and not at all, respectively. Some had problems with MSDOS
> 3.31 diskette images or 32MB virtual hard drives (the limit for DOS 3.31).
> Others had issues booting Windows under DOS 5.
>
> Has anyone successfully gotten Windows 1 to work within any virtual
> environment with working mouse support? If so, what was the exact software
> configuration so that I can replicate it here?
>
> Thanks!
>
> Rich
>
> --
> Rich Cini
> http://www.classiccmp.org/cini
> http://www.classiccmp.org/altair32
>
>



More information about the vcf-midatlantic mailing list