[vcf-midatlantic] Running Windows 1.04 in emulation

Richard Cini rich.cini at verizon.net
Thu Apr 28 08:54:21 EDT 2016


I did not know that. You mean mouse.drv from the Windows distribution disks? If that's the case then that should solve the problem. I have 2.x somewhere at home. 

I tried the USB dongle thing and VirtualBox on the PC couldn't map either \\.\COM3 or COM3 successfully, nor /dev/tty.usbserial on the Mac. Bochs I find a bit clunky to use and won't always boot every image I create. MSVPC is slick but won't work on Windows 10. 

PS/2 support across the virtualization a seems to be fine (the host mouse works in Norton Commander, for example). 

I was looking for a cross-platform (Mac and PC) solution so anyone could replicate it. 

Rich

Sent from my iPhone

> On Apr 28, 2016, at 8:18 AM, Corey Cohen <applecorey at optonline.net> wrote:
> 
> 
> 
>> On Apr 27, 2016, at 8:36 PM, Rich Cini via vcf-midatlantic <vcf-midatlantic at lists.vintagecomputerfederation.org> wrote:
>> 
>> Bill -
>> 
>> Thanks. If that's the case then it's an issue with how the Windows driver interacts with the virtual hardware as it doesn't work on any virtual setup I tried. One driver can be set for PS/2 and it finds the mouse but it's not captured. 
>> 
>> I have a real DOS machine in the shop and I will try to do an install on real hardware to prove that out. I'd really like to get this working in a virtual machine so others can experience it. 
>> 
>> Rich Cini
>> 
>> Sent from my iPad
>> 
>>> On Apr 27, 2016, at 10:04 PM, william degnan via vcf-midatlantic <vcf-midatlantic at lists.vintagecomputerfederation.org> wrote:
>>> 
>>> The model 25 collegiate kit ran 1.04 on two 720k disks with a ps/2 mouse.
>>> 
>>> Bill Degnan
>>> twitter: billdeg
>>> vintagecomputer.net
>>> On Apr 27, 2016 9:35 PM, "Richard Cini via vcf-midatlantic" <
>>> vcf-midatlantic at lists.vintagecomputerfederation.org> wrote:
>>> 
>>>> All —
>>>> 
>>>> I’m progressing well with the Windows 1.04 SDK -- I’ve gotten all of the
>>>> binders and books scanned. The software is fully captured and I’m trying to
>>>> create a “build environment” for this as a demo.
>>>> 
>>>> I’ve tried to get Windows to work properly in various combinations of
>>>> virtual environments with limited success. I’ve used Parallels on the Mac,
>>>> VirtualBox on the Mac and PC, Bochs on the PC and Microsoft Virtual PC on
>>>> the PC. I have a complete log of my findings if anyone’s interested.
>>>> 
>>>> Only Parallels on the Mac worked completely. On Microsoft VirtualPC under
>>>> Windows 7, it almost worked, but button clicks didn’t register. Bochs was
>>>> the worst performer.
>>>> 
>>>> Most of the issues have to do with capturing the mouse — Windows 1
>>>> predated PS/2 mice so a mouse has to be mapped to the virtual COM port or
>>>> the InPort bus interface, which the virtualizations seemingly do with
>>>> limited success and not at all, respectively. Some had problems with MSDOS
>>>> 3.31 diskette images or 32MB virtual hard drives (the limit for DOS 3.31).
>>>> Others had issues booting Windows under DOS 5.
>>>> 
>>>> Has anyone successfully gotten Windows 1 to work within any virtual
>>>> environment with working mouse support? If so, what was the exact software
>>>> configuration so that I can replicate it here?
>>>> 
>>>> Thanks!
>>>> 
>>>> Rich
>>>> 
>>>> --
>>>> Rich Cini
>>>> http://www.classiccmp.org/cini
>>>> http://www.classiccmp.org/altair32
> 
> I had Windows 1.04 running in emulation in on MacBook Air.   The problem was the mouse driver.  If I recall I used dosbox in PCjr mode and mapped the serial driver to a serial usb converter and used my green eye Microsoft mouse when I was sorting out how to run it on my PCjr for VCF east last year.  
> 
> BTW I know you can use the driver from Windows 2.0 to add ps/2 mouse support to use the mouse support dosbox.  I assume you want to do it differently.   
> 
> Cheers,
> Corey
> 
> corey cohen
> uǝɥoɔ ʎǝɹoɔ



More information about the vcf-midatlantic mailing list