[vcf-midatlantic] Kaypro 10 ROM question

Douglas Crawford touchetek at gmail.com
Sat Aug 27 17:36:41 EDT 2016



On 8/27/2016 4:30 PM, Mike Loewen via vcf-midatlantic wrote:
> On Sat, 27 Aug 2016, Douglas Crawford via vcf-midatlantic wrote:
>
>> On 8/26/2016 7:45 PM, Mike Loewen via vcf-midatlantic wrote:
>>>
>>>     Any Kaypro experts here?
>>>
>>>     I'm in the process of installing a KayPLUS ROM in a Kaypro 10, in
>>>  preparation for installing a new (larger) hard drive. My K10 has a 
>>> 81-180
>>>  series mainboard, but the sticker is missing from the factory ROM 
>>> and I
>>>  can't tell which one it is. It powers on to display version 1.9e. 
>>> Assuming
>>>  that this is an '83 version mainboard, the ROM should be 81-302. Can
>>>  someone confirm which ROM version displays 1.9e?
>>>
>>>     I've successfully burned a 2764 with the kplus83.rom image and 
>>> made the
>>>  hardware modifications described in the KayPLUS manual. However,
>>>  absolutely nothing happens when I power up. Everything works fine 
>>> when I
>>>  replace the original ROM. I want to make sure I'm following the right
>>>  instructions for my combination of mainboard and ROM.
>>>
>>>
>>>  Mike Loewen                mloewen at cpumagic.scol.pa.us
>>>  Old Technology http://q7.neurotica.com/Oldtech/
>>
>> Mike I have the same machine torn down due to funky hard drive also.
>> Same rom version here as reported on the screen and the sticker is in 
>> place on the ROM 81-187.
>> See 2nd pic here of mine:
>> http://imgur.com/a/UzZBR
>> I did some research and found pictures of the '83 models that were 
>> the same as my MB
>> that's how I figure its an '83.  The '84 moves the HD connector to 
>> the card edge by
>> the floppy connector.  I'm trying to decide if its better to just 
>> start with the '84 and
>> leave the '83 go.
>> Seems to me that ROM you made should have worked.
>> I may or may not go with any of the ROM updates such as KayPLUS.
>> Reading various sites shows me its hard to nail down a sure road to 
>> success, I hate to say.
>> I may stay with a MFM drive instead.
>
> Doug:
>
>    The 81-187 ROM is actually the Character Generator ROM, not the 
> BIOS ROM.  The BIOS ROM is underneath the ribbon cable that goes to 
> the hard drive interface board.  From what I've read on the Vintage 
> forum, I have the 81-302C ROM.
>
> http://www.retroarchive.org/maslin/roms/kaypro/index.html
>
>    Based on another message thread, I burned another 2764 with the 
> kplus84.rom file, and I now get the KayPLUS message at powerup and I 
> can boot the machine from a floppy generated by the KPCNFG84 utility.  
> The remaining task is to get it to talk to the hard drive, as there 
> appears to be a compatibility issue between the KayPLUS ROM and the 
> hard drive interface board that connects to the WD1002 controller.  
> See this thread:
>
> https://groups.google.com/forum/#!topic/comp.os.cpm/IRXsnekNgSg
>
>    I'll probably do a quick bypass on the reset line to the WD1002 to 
> get it running in time for VCF Midwest, then put in a permanent fix 
> later.
>
>
> Mike Loewen                mloewen at cpumagic.scol.pa.us
> Old Technology                http://q7.neurotica.com/Oldtech/
>
>
Ah, the label is missing off of the EPROM under there on mine too.
I read that post before and it was one of the things that dissuaded me 
from continuing.
Skimming down I saw more confusing and folks going back and forth
between the KayPLUS and the TurboROM, software reset vs power on reset...
And ending without anyone saying they were happy with their mods, and 
someone dropping
out of communications...
I bailed.




More information about the vcf-midatlantic mailing list