[vcf-midatlantic] PDP 11/40 finally got it working better-er

william degnan billdegnan at gmail.com
Wed Jun 29 23:51:15 EDT 2016


For many years I have been working off and on to get my pdp 11/40 running.
  I was having trouble getting past "chase the lights" and simple tests.  I
was even able to load in a papertape.  It was in memory ok but never ran
 .I got a lot of good advice but nothing seemed to work.  I made sure
everything was correct on the backplane and RAM was ok.  Some important
diagnostics simply would not run however.  I was stuck.

After a lot of spinning my wheels finally I discovered the CPU was wired
for a KJ11 module (stack limit register) but I did not have one installed.
I was having problems with code that included the stack so there you go
makes sense now....but it took a while.  Part of the problem is that I
always thought the KJ11 and KW11-L (line time clock) were always paired
up.  This was not a logical reasoning, it was only because I always saw
them paired that way and I assumed they were a set.  I even had in the past
tested the system with both installed but it froze things so I abandoned,
never thought to try just one or the other alone.  But apparently that
would have been the ticket, my system CPU was wired for the KJ11 only.  I
tried just the M7237 and poing it worked.  I finally was able to run
complex diagnostics and I even downloaded BASIC from papertape and ran it
(much faster than 11/05 btw)

Here is the page with more info
http://vintagecomputer.net/browse_thread.cfm?id=635

Next I can try to boot an RT11 RL02 pack from an RL11 controller (M7762).

If anyone is going through the same thing how to troubleshoot a lot of the
UNIBUS stuff let me know happy to try to help.


Bill
-- 
@ BillDeg:
Web: vintagecomputer.net
Twitter: @billdeg <https://twitter.com/billdeg>
Youtube: @billdeg <https://www.youtube.com/user/billdeg>
Unauthorized Bio <http://www.vintagecomputer.net/readme.cfm>



More information about the vcf-midatlantic mailing list