[vcf-midatlantic] ADTPro help

Systems Glitch systems.glitch at gmail.com
Tue May 24 15:24:29 EDT 2016

I looked through the adtpro.sh file for version 2.0.1, which I have running just fine under Slackware 14.1 64-bit. The script picks the version of RXTX based on your system's `uname` and `uname -p`, so that should be fine for your machine. I seem to remember having permissions issues on lockfile creation, so you may be running into that.

Things to do:

* Run it in the console, give us the complete output
* Do `ls -l | grep lock`, give us the output
* Do `groups`, give us the output
* Do `ls -l /dev/tty*`, give us the output

As always, don't include the backticks!


On Tue, 24 May 2016 12:39:23 -0400
Evan Koblentz via vcf-midatlantic <vcf-midatlantic at lists.vintagecomputerfederation.org> wrote:

> I last used ADTPro about a year ago. It worked fine. A few months ago I 
> installed a new mobo/memory/processor in my daily PC (still running 
> Ubuntu). Yesterday I tried ADTPro again and got this error message:
> "There are no serial ports, or the serial library RXTX is not installed 
> or visible."
> Paul H. suggested that the adtpro.sh file was looking in the wrong place 
> for RXTX. Made some tweaks but it's still not working. Note also that 
> ADTPro has its own copy of RXTX in a subfolder. Stephen E. also tried to 
> help.
> Can someone who is experienced at both ADTPro and Linux (and who has the 
> patience to walk me through this) help me, please?
> Hoping to get some help via telephone or Skype today/tonight if possible.

More information about the vcf-midatlantic mailing list