[vcf-midatlantic] VMS question

Jason Howe jason at smbfc.net
Fri Oct 20 00:03:55 EDT 2017


Hrm.  If I can manage it this weekend, I'll pull out my DEC 3000.  I 
*think* I built a newuser script which takes care of enough stuff to 
just allow a login for a new user without any hassle.

I have a vague recollection of an ssh difficulty on first login and that 
telnet or a console login for the first login was most reliable.  That 
might be specific to VMS 8.4 or just my setup though.

--Jason


On 10/19/2017 02:22 PM, william degnan via vcf-midatlantic wrote:
> Update complete, but it still kicks the user out after logging in.  I think
> you fixed a different issue.  What else can I check?  I had this same
> problem and you fixed it for me at VCF East 12.  I have notes about other
> stuff we did on the system, but not about the users.
>
> Username: EKOBLENTZ
> Password:
>          Welcome to VAX/VMS version V5.5-2 on node COBUCK
>      Last interactive login on Thursday, 19-OCT-2017 15:14
> %Sorry, your default device is unavailable for login, try again later...
>
>    EKOBLENTZ    logged out at 19-OCT-2017 15:14:38.56
>
> B
>
> On Thu, Oct 19, 2017 at 5:10 PM, william degnan <billdegnan at gmail.com>
> wrote:
>
>> OK.  Thanks for fixing my structure, I would not have caught that.
>> Bill
>>
>> On Thu, Oct 19, 2017 at 4:18 PM, Brian Schenkenberger via vcf-midatlantic
>> <vcf-midatlantic at lists.vintagecomputerfederation.org> wrote:
>>
>>> william degnan via vcf-midatlantic writes:
>>>
>>>> A while back I was working on my MicroVAX and I had a few OS and hardware
>>>> setbacks.  I have finally gotten back to where I was before.
>>>>
>>>> So, I have a question for you VMS admins out there.
>>>>
>>>> I can log into my Microvax 3100 as SYSTEM remotely the FQDN is
>>>> microvax3100.vintagecomputer.net. I am having issues adding new users.
>>> I
>>>> remember asking about this problem a year ago and Brian helped me fix it
>>> at
>>>> VCF E 12 I think, but I forget how he fixed it.
>>>>
>>>> I can create a user (for Evan K to try) and I can log in, but it
>>>> immediately logs me out.  I get the following error:
>>>>
>>>> Username: EKOBLENTZ
>>>> Password:
>>>>         Welcome to VAX/VMS version V5.5-2 on node COBUCK
>>>>     Last interactive login on Thursday, 19-OCT-2017 15:14
>>>> %Sorry, your default device is unavailable for login, try again later...
>>>>
>>>>   EKOBLENTZ    logged out at 19-OCT-2017 15:14:38.56
>>>>
>>>> I remember Brian S fixed this problem, and it's not a user setup issue
>>>> within AUTH, there is something else I need to do to allow non SYSTEM
>>> users
>>>> to log in.
>>>>
>>>> This is not a production server but I do have it up and running now, if
>>>> anyone who can advise needs the SYSTEM password just send me an email
>>> and I
>>>> will send to you.  Please if you fix, I need to document the fix so I can
>>>> know how to create a new user.
>>>>
>>>> Here is the process I am using:
>>>>
>>>> $ set process/privileges=all
>>>> $ set default sys$system:
>>>> $ run authorize
>>>> UAF> show [100,*] /brief
>>>> UAF> add EKOBLENTZ /uic=[100,30] /account=COBK
>>>> UAF> modify EKOBLENTZ /password=password
>>>> UAF> modify EKOBLENTZ /device=sys$sysdevice      <=== L@@K
>>>> UAF> modify EKOBLENTZ /directory=[EKOBLENTZ]     <=== L@@K
>>>> UAF> modify EKOBLENTZ /owner="Evan Koblentz"
>>>> UAF> modify EKOBLENTZ /nopwdexpir /flag=nodisuser
>>>> UAF> modify EKOBLENTZ /defprivileges=(TMPMBX, OPER, NETMBX)
>>>> /privileges=(TMPMBX, OPER, NETMBX)
>>>> UAF> modify EKOBLENTZ /flags=nodisuser
>>>> UAF> exit
>>>> $ create /directory /owner=[100,30] COBK$DATA:[COBK.PERSONAL.ekoblentz]
>>> <=== L@@K
>>>> /OWNER=[ekoblentz]
>>>>
>>>>
>>>> SO...What else do I need to do?  I know my SYSTARTUP_V5.COM is a little
>>>> screwy (yes I am using VMS 5.2) and I need to clean it up, but I don't
>>>> think the problem described above is related to the system start
>>> script.  I
>>>> seem to remember Brian going into a directory someplace and adding the
>>> user
>>>> to a table or changing the system to allow a certain user to be able to
>>> log
>>>> in.  What I'd like is to allow any user I create by default to be allowed
>>>> to log in, if they have the correct permissions as a user.
>>>>
>>>> Thanks
>>>>
>>>> Bill
>>> You have created/established Evan's account with a default "home"
>>> directory of
>>> SYS$SYSDEVICE:[EKOBLENTZ] but you created COBK$DATA:[COBK.PERSONAL.EKOBL
>>> ENTZ].
>>>
>>> Either:
>>>
>>> (1)
>>>
>>> $ MCR AUTHORIZE
>>> UAF> modify EKOBLENTZ /device=COBK$DATA:
>>> UAF> modify EKOBLENTZ /directory=[COBK.PERSONAL.EKOBLENTZ]
>>>
>>> ...or...
>>>
>>> (2)
>>>
>>> $ CREATE/DIRECTORY SYS$SYSDEVICE:[EKOBLENTZ]/OWNER=[100,10]
>>>
>>>
>>> Remember, computers only do what you tell them to do. ;)
>>>
>>>




More information about the vcf-midatlantic mailing list