[vcf-midatlantic] Atari XE game system

David K davekre17 at gmail.com
Tue Aug 18 21:23:22 EDT 2020


I recently bought an Atari XE game system.  When I turn it on it goes right
into self test.  The result of the self-test is that the ROM 'slot' on the
left is green (good) but the ROM 'slot' on the right is bad (red).  All of
the 48 RAM blocks show up as good.  I get this same result every time I
turn it on or reset it.

I have tried starting the computer while holding 'Select' and the exact
same thing happens.

I am confident the power supply is good.  I am actually using a 5V power
supply for an Atari 800XL I have and it works for the XL just fine.

I took the motherboard out of the case and can see no obvious damage (I am
not an electronics or computer person by training however).

I tried numerous games and none worked except one (see next paragraph).  I
know the games are good because they work on my XL.

The one game that does work is Star Raiders.  I saw something online about
how this has some special testing (?) component but I do not understand the
implication of this.

I have the keyboard piece and it seems to work as I can use it to do
various things when playing Star Raiders.  But pressing the 'Help' button
on the keyboard during the self test does nothing.

I've left the computer on for maybe 15 minutes as it repeatedly goes
through the self test and some of the chips get warm but not particularly
hot.

Can anyone help me get this to boot correctly and play other games?

Thanks,
David K


More information about the vcf-midatlantic mailing list