[vcf-midatlantic] Xerox Status

David Gesswein djg at pdp8online.com
Thu Aug 20 22:05:58 EDT 2020

As previously reported I worked on the Xerox at this workshop.

Short summary: One of the two machines hardware seems ok. Was able to boot
it. Second machine has a hardware fault. Major issue before machine is usable
is to make a replacement for the missing mouse.

Poor picture of what was a nice looking display booting the Interlisp-D
that was on the hard drive.

The TL;DR to document what we did. People continuing work should at least
read the remaining issues at the bottom.

VCF has two Xerox 1108 Dandelion AI machines made in 1985. This model
was introduced in 1981 if you trust online sources. The hardware is identical
to the 8010 Star Information System except possibly it should have a three 
button mouse instead of a two button mouse. The AI machines shipped with
Interlisp-D and the Star with office software.  I'm not an expert on the 
somewhat confusing models, operating systems, and names.

The machine I started with last time still had the problem of the diagnostic
screen cycling through the boot options. This is supposed to happen when you
push a button on the control panel. Swapping the control panel did not fix it.

I then pulled the cards to disconnect them on the second machine and verified
the power supply was ok. Plugged the cards in and diagnostic display seemed
to behave. I had tried to make a diagnostic boot floppy from image online
but I didn't think it was good. The machine also didn't like it.

>From the previous workshop the hard drive didn't want to spin up. I pulled it
from the machine to work on. The motor seemed fine but the spindle was very
stiff. I put some oil on the outer spindle bearing under the pulley and let
it sit for a while hoping some got in. It started to spin but the belt popped
off as it started to get up in speed. By holding down the belt was able to get
the drive to spin up and it quieted down after a little running. Made
intermittent noise but nothing horrible. Heads wouldn't move. I opened
the warranty void stickers to get access to a hole in the cover that lets you
poke the heads to free them. There is a rubber stop for the head that had
become gummy in these drives (Quantum 2040). With the heads free it did its
calibrate sequence and I was able to read the drive with my MFM reader
emulator tool. Drive was serial number c133708 and only had one bad

I also repeated this with the second drive. Its pretty quiet but also has
the bad stop. It required some fiddling with the reader to read which
I haven't investigated why. Drive was serial number 102842 and only
had two bad sectors. This drive from the working machine had the nice 
background picture when I booted the image.

When we first booted the machine it looked like it worked but nothing
was displayed on the monitor and no evidence that the monitor was alive.
Ian opened it up and we found the board was off the CRT pins. Nothing looked
damaged. When we tried again we got a dim picture. With time it got somewhat
brighter and some adjusting of pots we got a good looking display. After
we put it back together one of the diagnostics showed it was a little offset
to the right but don't think it matters.

Due to the bad head stop which is likely to restick the heads Jeff and I
decided to use an emulator for the drive. This will also allow switching which
operating environment is running if we wish to show the various options.
Unclear if the bearings will be ok with running or will get worse.
The rubber bumper is on the down side so shouldn't ooze onto the platters.
Unknown if it is outgassing anything bad. The stop should be able to be
replaced but would either require arthroscopic surgery or removing the
platter cover.
Some info on my previous successful and not so sucessful working on
these drives.

Ian Primus was leading the mouse effort. He tried to make an adapter
for a Xerox mouse from a later machine. Either it doesn't operate how we
think or the chip is bad. He made an adapter for a Amiga mouse which the
Xerox responded to the buttons and the cursor jittered around but couldn't
move properly. He found further information on the interface and it was using
a special encoding, not quadrature that the Amiga generates. Ian and other
were discussing how to make a functional mouse. I'll let them fill in the plan
if they desire.

I tried the viewpoint image for the Darkstar emulator that I converted to 
the MFM emulator format. It generated error codes 0002 and 0322 which is
Ethernet faults. I put on a AUI to 10-base-T transceiver and plugged in
a crossover cable to my laptop but it still generates the fault. Holding down
the button until 1 is displayed to bypass the diagnostic allowed it to boot.
It got to the login prompt. Without a functional mouse we couldn't get further.

Discussing with Jeff we decided that Viewpoint would be the best operating
system to use for the museum display. I left the emulator configured to
boot Viewpoint.

This page give information on running Viewpoint. You can also use the
emulator to practice with it.

I cleaned up the monitor, keyboard, and plastic skins on the computer. Some
of the skins were damaged so I cleaned the best looking. On putting them back
on in the warehouse I couldn't get them to fit properly. Either it was just
too dark or they aren't interchangeable. If so you may need to clean the
other skins. We didn't mark with machine they came from.

I also put on casters. We didn't try to match the missing originals, they
are what Home Depot had. Jeff Brace picked them up for me.

During this I also checked the power supply under load. All were ok except
5.2 was low at the test connector on the front of the machine. It was around
4.8 volts. It was around 5.1 at the supply. Poking around to try to determine
where the voltage drop was it improved to about 5V at the test connector so
likely high resistance connection that improved with moving wires. 5.02
is the lower limit according to the manual. I didn't see a ripple
specification and didn't check ripple. I though about looking for a tweak
pot to raise it .1V but decided not to spend the time. Both machines were
similar for 5.2 volt output including improving with poking at wires.

This is where time was up. Another workshop should get it ready to use.
Ian will be leading that effort. I will not be able to make the next couple.

I was not able to run full diagnostics. Also have not verified if the floppy 
drive is functional.

*** Remaining issues I know of. ***

1) Make suitable mouse.

2) Emulator needs to be mounted in the machine. Currently its in an antistatic
bag above the power supply. Two options:
  a) Remove the hard drive and mount it in its place. Their is a #8 coarse
thread hole which could be used to attach the emulator if a suitable
bracket is made. I can make one if people like this route. The disadvantage
is the hard drive will need to be removed from the computer.
  b) Make longer cables and mount it above the power supply. Longer 50,
20 pin, and power cables cables would need to be made and suitable mounting
method made. Possibly just some plastic shields so it can short to anything
is sufficient. Longer cables should work but can't be sure until tried.

3) Check power supply 5.2V on front connector to see if it is still around
5V. Page 6-10, 95 in PDF of this manual has the test connector information.

4) The foam in the computer is deteriorating. Its currently at the does
not spring back stage. Does not seem to be crumbling or generating corrosive
gasses. One of these will likely happen with more time so should be addressed
at some point. Most of it is just for sound deadening so can be removed with 
the machine being somewhat louder.  I like to replace it on my restorations. 
There was a bigger piece on the front skin that looks like they put it in
for some purpose that we may not want to just remove.

5) Check if skins I cleaned fit properly.

6) There are various scuff marks I didn't bring strong enough cleaner to
remove on the skins. Does not need to be addressed but will make it look 
nicer. I've had good results on plastic with scuffs using soft scrub.

7) May want to try to understand the Ethernet error though its easy to
work around.

More information about the vcf-midatlantic mailing list