[vcf-midatlantic] Last workshop report

David Gesswein djg at pdp8online.com
Fri Feb 7 22:20:16 EST 2020

   Executive summary: I checked out the two 3B1's in the museum. One had
hardware mods to allow more and larger disks and is functional though the
drive doesn't want to reliably spin up. The second has a motherboard fault.
I also updated the image on the 3B1 in the Museum and added a USB cable
hidden behind the center expansion board cover to allow easier updates to the
disk image.  Due to the rain and the filler work running long the Xerox 8010
didn't get that much work done. It appears to have a hardware fault though
was running some. Fault may just be with the control panel. The hard drive
wouldn't spin properly, likely loose belt. The second Xerox was not 
investigated at all.


   The plan was to mostly work on the Xerox 8010 Star/Dandelion but we
decided to not try to move it in the heavy rains Saturday so I did more
3B1 work. I checked out the two 3B1's in the warehouse and removed the
batteries from both.

   The first one with sticker NCR SN 02233914 on the side was interesting. 
The motherboard had been modifed to the P5.1 motherboard configuration.
This change was under development when AT&T killed the UNIX PC line. The
last software supported it but the updated motherboard was not shipped.
P5.1 increases the number of heads supported from 8 to 16.
   The hard disk controller chip was also changed to the WD2010 which allows 
the number of cylinders to be increased from 1024. The chip supports 2048 but 
the operating system limit is 1400. 
   It also had the modification to support a second hard drive. You can see 
the grill for one of the fans had been cut down to allow the cables for the 
second drive to exit the case for an external drive at some point. The fan 
was reinstalled and no cables are present for the external drive. Currently 
it is configured with a single DEC RD54 hard drive. The drive capacity is 
152 MB vs the standard configuration of 67 MB.
   I removed the RD54 to backup with my reader. It initially didn't
want to spin up but with some light hits to spin it around the spindle
axes it spun up and I was able to read the drive. The MSB for the head
was put in the sector number byte since the WD2010 only supports 8 heads.
I hadn't run across a machine with the P5.1 mods so had to fix my 3B1 decoding
to match.  The drive label had 42 defects listed. I found 7 sectors with read 
errors, the first 5 matching sectors in the defect list.
   The machine has 2 MB on the motherboard and a 2 MB memory expansion board
so has the maximum amount of memory supported.
   It also has a floppy tape drive expansion board and cable with it. I forgot
to dig around on the shelf rack to see if the drive was around. May be good to 
see if the drive is around so it can be kept together with the computer.
   This machine had the battery holder installed. I removed the BR2325 battery.
You likely can install a BR2330 to get a little longer life. BR2330 is the
battery I have in the museum 3B1.
   After I put everything back together the computer was running but the hard
drive wasn't spinning up. Likely the drive is unhappy. I didn't open it back 
up to check that I got the power plug fully seated. I also did not test the
floppy drive. This machine is more tricked out than the one in the museum
except for not having the DOS expansion board.
   I haven't looked that much at the disk image. It does have some things
I haven't seem before, a CAD program and an office suite Smart Software
System with wordprocessor, database, spreadsheet, and spellchecker.
It had noticable usage by one user and a couple other accounts.

A few pictures here http://www.pdp8online.com/3b1/vcf-p5.1/pics.shtml

   The second 3B1 is labeled 370429065 on the bottom. I was able to read the 
drive but it had 50 bad sectors and got worse with further read attempts.
The drive didn't sound too bad. It's possible that the drive is useable
with a reformat. The system files were similar to the previous machine and
it only had one user account with no significant content so I didn't try
harder to recover the bad sectors.
   This machine does not complete its power on diagnostics. It has one green
LED lit which indicates that the video ram failed its test. I did not
try to fix the fault. This machine still had the soldered in battery so I
cut it out. It was a CR2430. 
   It has a dual serial port expansion board installed without memory 
installed so only has the 2 MB on the motherboard.

   I opened the museum 3B1 and ran a USB cable from the emulator with the end
tucked above the center expansion slot memory board. It can be accessed
by removing the center slot cover. It is a USB-C connector. I updated the
image with some more demo software. Some of the additions are it has BASIC,
Logo, gcc, Microsoft Word & Multiplan, simple hello world in C, BASIC, and 
Logo, a ~10 line Logo program which draws a tree and the software to use the
DOS coprocessor board. I need to write up a description of how to use the
stuff installed. I demoed at the workday.

   Connor was working on a VAX which didn't want to boot. We used my mfm board
to verify that the RD54 drive wasn't going ready. Comparing to the 3B1 RD54
it sounded like the heads were stuck. He opened the drive and it had a
deteriorating rubber stop for the heads that was likely preventing them
from moving. It was a blue rubber ring on the bottom plate of the drive
and reasonably accessible. He removed as much of it as he could and the
heads properly went through the startup sequence.
   I tried to read the drive with my mfm board and it had an excessive number
of read errors to be useful. I did verify it was a VMS disk. It appears to
have the problem commonly seen where the head stack is out of alignment.
Some of the heads are so far out of alignment you read the data from the
next cylinder. Drive may be recoverable with methods like this.
   Connor pulled 2 more RD54's from warehouse machines to try to get a good 
image for the emulator in case we can't get one formatted by the VAX. One drive
wouldn't work, I think stuck heads again. The other was readable. It was
from a PDP-11, possibly a 73. It is RT-11 with KASTLE SYSTEMS building
monitoring software.

   Only a few hours were left when I got to the Xerox 8010. I pulled the boards
and power to the hard drive and verified the power supply voltages were 
within specification. I also inspected for anything suspicious. For some reason
the floppy drive power and data cables were disconnected.
   I released the spindle and head shipping locks on the hard drive and
verified the spindle would turn.  I hooked up my mfm board and tried to read 
the drive. The drive barely spun. I think the belt is slipping. I didn't
have time to remove the drive from the machine to work on further.
   We installed the cards and powered on the machine after Connor found the
power button hiding behind a cover. As previously reported
the diagnostic display counted from 0 to 10 repeatedly. If I understand the
documentation, the machine is supposed to cycle through these codes when the
alt boot button is pressed and you release it when the code matches the 
operation you wish to perform. I played with the button but it still always 
went though the 0-10 sequence. It is reading the button as always depressed.
The reset button next to it did function.
   The hard drive power is currently disabled and the shipping locks installed.
The floppy power and data cables were reconnected.
   The machine is missing its castors. They need to be replaced. It still
needs cleaning. The one I was working on one of the side panels is broken
at the bootom. I think the other machine had a good side panel. Their is some
rust but the machine looks in reasonable condition.
   I did not do any testing on the second machine.

More information about the vcf-midatlantic mailing list