[vcf-midatlantic] Altair cant jump

William Dudley wfdudley at gmail.com
Sat Jun 13 09:16:08 EDT 2020

Either a bad CPU or bad memory (more likely).  If you (or the cpu)
can read memory reliably single stepping, but not at speed, that
suggests memory accesses at speed are flakey.

If there's a way to cut the clock speed down, I'd try that.  If it runs
reliably at lower clock speed, then memory access is your problem.

I can't explain failing to jump when single stepping.

Bill Dudley
retired EE

This email is free of malware because I run Linux.

On Fri, Jun 12, 2020 at 11:54 PM Jeffrey Golas via vcf-midatlantic
<vcf-midatlantic at lists.vcfed.org> wrote:
> So I’ve been battling my (new to me) Altair for some time trying to get a simple serial echo program to work. Im entering all code via the front panel. Im not 100% this thing is working though it mostly seems to be. Ive done the kill-the-bit game and played music to an AM radio.
> Current config is Altair with rev0 main board, aftermarket (beefy) power supply, a CCS 16k ram board, and a Cromemco TU-ART serial board. Nothing else.
> The problem Im having is the echo program which Im mainly transcribing from the TU-ART manual goes off the rails. It runs differently every time Ive run it, and usually starts spitting out junk data after press one key (its supposed to read one char and send it back). It makes no sense to me. Stack is set right, and one change I made was changing from a JR to JMP as the 8080 doesnt do relative addressing. Ive verified numerous times its all correct.
> Single stepping it for the most part seems to work, and today I manually single stepped through the entire process only to have the single character come through properly. If I run it, it goes nuts and dumps data. Ive confirmed the status byte its reading from the board is correct and changes as it should.
> I may have discovered the issue though: it wont jump. I even tried a simple few bytes to have it store FF and 00 to memory to verify its working(it does), but doing a C3 00 00 to jump back to zero, it single steps right past that. I think this may be my problem, but how do I fix that? Bad cpu?
> TIA!
> Jeff G aka Bags

More information about the vcf-midatlantic mailing list