[vcf-midatlantic] Strange Commodore 1581 floppy drive issue

Russell LeChard russell.lechard at gmail.com
Mon May 16 15:02:22 UTC 2022

Good Morning All. I am seeking some help from some Commodore experts with a
Commodore 1581 floppy Disk drive.

Some background:

I've been an IT specialist specializing in IBM and compatible PCs since the
early 90's. However, I started my computing journey with the TRS-80 model
III and  Commodore 64. I fell in love with the C64, and it began my start
in a very successful career in IT. (see attach photo of my c64 setup in
1986 LOL)

Recently I was lucky enough to find a C64C, a C128, and a 1581 3.5 floppy
drive online for a reasonable price. Well, I did pay a premium for the
1581, but I never had one back in the day and well, I treated myself..

This past weekend I tested all 3 items and for the most part all worked OK.
I was concerned the most about the 1581 working. After a delay in
remembering the correct syntax for the C64 format disk command (open
15,8,15,"N0:testdisk,01": close15) - My memory isn't what it was in my
younger days! LOL :-D), I was able to format a disk and then save a simple
basic prg to it. However, when I try to load this basic prg (on the C64),
it locks up the c64 and there seems to be no activity led lights and the
1581. I need to reboot the C64.

Now, I tried the same task using the c128 and the same 1581 and floppy
disk, I can now format, save, and load a basic prg without any issues.
Everything seemed to work fine. My question is, are there any known
compatibility issues between the C64C and the 1581 that the c128 fixed? I
always thought the 1581 was compatible with the C64 and c64C? Very Strange.
Any thoughts and advice are welcome.Thank you in advance.

Take Care,
Russell LeChard

More information about the vcf-midatlantic mailing list